We're updating the issue view to help you get more done. 

Deleted attributes not deleted from fulltext index

Description

Having deleted attributes from an entity, the fulltext search still finds the entity on the deleted content. It seems that the data isn't deleted from the fulltext index. This is a very serious bug in my opinion - it causes mistaken results, and users have no way to correct the mistakes (apart from reindexing which isn't for ordinary users and seems to be risky on larger databases).

Environment

devel. branch (cleanup_before_release), using Mysql fulltext

Activity

Show:
User known
February 22, 2011, 9:10 AM

If you can let me actually log into both the running system and MySQL then yes, it would be a huge help.

User known
April 19, 2011, 9:44 PM

This has been fixed in SVN cleanup_before_release. Give it a try and let me know if it works for you.

Michal Frankl
April 21, 2011, 9:34 AM

Thanks, but I'm afraid the problem still persists.

I delete a row (an attribute of an entity) and add another one. After saving the changes, I still find the entity on the deleted attribute.

User known
May 1, 2011, 7:50 PM

Ok, there were some cases I had missed
I just checked in some new changes to cleanup_before_release in SVN r7183 that should finally fix all of this (fingers crossed). Please try them out and let me know...

seth

User known
May 23, 2011, 12:57 PM

I believe this is resolved now?

Assignee

User known

Reporter

Michal Frankl

Labels

None

Priority

Blocker
Configure