We're updating the issue view to help you get more done. 

Zend Locale error when upgrading Providence to 1.7.8

Description

We tried to upgrade Providence from 1.7.1 to 1.7.8 and we got following error:

Cannot declare class Zend_Locale, because the name is already in use in <collectiveaccess>/app/lib/Zend/Locale.php

Environment

Tested with PHP 5.6, 7.2 on Debian Buster

Activity

Show:
Seth Kaufman
February 5, 2020, 12:12 PM

First of all, only use 1.7.8 with PHP 7.2, not 5.6. Secondly, be sure to recreate your setup.php file using the setup.php-dist template that is part of 1.7.8. Don't use the setup.php from 1.7.1. Finally, be sure to restart your web server after updating. If you're running OpCache there's a chance it's still got the old code cached.

Aneta Plzáková
February 5, 2020, 12:17 PM

Thank you very much, Seth. We will try as soon as possible and let know whether it worked.

Sincerely

Aneta

Assignee

Seth

Reporter

Aneta Plzáková

Labels

Affects versions

Priority

Blocker
Configure